Creates an advanced loss factor object with the given values.
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ballastLossFactorIn
- Type: SystemDouble
The ballast loss factor as a numerical value between 0.0 and 1.0.
- lampLumenDepreciationIn
- Type: SystemDouble
The lamp lumen depreciation loss factor as a numerical value between 0.0 and 1.0.
- lampTiltLossFactorIn
- Type: SystemDouble
The lamp tilt loss factor as a numerical value between 0.0 and 1.0.
- luminaireDirtDepreciationIn
- Type: SystemDouble
The luminaire dirt depreciation loss factor as a numerical value between 0.0 and 1.0.
- surfaceDepreciationLossFactorIn
- Type: SystemDouble
The surface depreciation loss factor as a numerical value between 0.0 and 1.0.
- temperatureLossFactorIn
- Type: SystemDouble
The temperature loss factor as a numerical value between 0.0 and 2.0.
- voltageLossFactorIn
- Type: SystemDouble
The voltage loss factor as a numerical value between 0.0 and 2.0.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The loss factor is not valid because it is not between 0.0 and 1.0. -or- The loss factor is not valid because it is not between 0.0 and 2.0. |