InsertNewAssetPropertyDouble Method


Inserts a new AssetPropertyDouble containing the input value to this list.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.1

Syntax

C#
public void InsertNewAssetPropertyDouble(
	double value,
	int index
)
Visual Basic
Public Sub InsertNewAssetPropertyDouble ( _
	value As Double, _
	index As Integer _
)
Visual C++
public:
void InsertNewAssetPropertyDouble(
	double value, 
	int index
)

Parameters

value
Type: SystemDouble
The double value to insert.
index
Type: SystemInt32
An integer index.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException index is out of range.
Autodesk.Revit.ExceptionsInvalidOperationException The asset property is not editable.

See Also