ConvertToRealSheet Method


Converts a placeholder sheet to a real one with an optional titleblock.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public void ConvertToRealSheet(
	ElementId titleBlockTypeId
)
Visual Basic
Public Sub ConvertToRealSheet ( _
	titleBlockTypeId As ElementId _
)
Visual C++
public:
void ConvertToRealSheet(
	ElementId^ titleBlockTypeId
)

Parameters

titleBlockTypeId
Type: Autodesk.Revit.DBElementId
The id of the placeholder sheet, or invalidElementId if no titleblock should be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException titleBlockTypeId does not correspond to a TitleBlock type.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This method may only be called on a placeholder sheet. -or- Failed to convert the sheet because the input titleblock could not be applied.

See Also