CheckAnalysisType Method


Checks that the analysis type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool CheckAnalysisType(
	AnalysisMode analysisType
)
Visual Basic
Public Shared Function CheckAnalysisType ( _
	analysisType As AnalysisMode _
) As Boolean
Visual C++
public:
static bool CheckAnalysisType(
	AnalysisMode analysisType
)

Parameters

analysisType
Type: Autodesk.Revit.DB.AnalysisAnalysisMode
The analysis type to be checked.

Return Value

True if the analysis type falls within an appropriate range, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also