Removes member element ids from the mechanical equipment set.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elemIds
- Type: System.Collections.GenericISetElementId
Element ids to be removed from the mechanical equipment set.
Remarks
If all the members are removed, the instance of the mechanical equipment set is automatically deleted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | One or more element ids was not permitted to be removed from the mechanical equipment set. All elements should be a member of the mechanical equipment set. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |