Cancel Method


Cancels the edit scope.

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.1

Syntax

C#
public void Cancel()
Visual Basic
Public Sub Cancel
Visual C++
public:
void Cancel()

Remarks

All the changes made after starting the EditScope will be discarded.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException EditScope is not active. EditScope can only be committed or cancelled when it is active. -or- EditScope cannot be closed, there is no opened transaction.

See Also