Create3DOrthographic Method


Creates a new orthographic 3D assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static View3D Create3DOrthographic(
	Document document,
	ElementId assemblyInstanceId
)
Visual Basic
Public Shared Function Create3DOrthographic ( _
	document As Document, _
	assemblyInstanceId As ElementId _
) As View3D
Visual C++
public:
static View3D^ Create3DOrthographic(
	Document^ document, 
	ElementId^ assemblyInstanceId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DBElementId
Id of the assembly instance that owns the new view.

Return Value

A new orthographic 3D assembly view.

Remarks

The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException assemblyInstanceId is not an AssemblyInstance.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also