CreateDetailSection Method (Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean)


Creates a new detail section assembly view for the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static ViewSection CreateDetailSection(
	Document document,
	ElementId assemblyInstanceId,
	AssemblyDetailViewOrientation direction,
	ElementId viewTemplateId,
	bool isAssigned
)
Visual Basic
Public Shared Function CreateDetailSection ( _
	document As Document, _
	assemblyInstanceId As ElementId, _
	direction As AssemblyDetailViewOrientation, _
	viewTemplateId As ElementId, _
	isAssigned As Boolean _
) As ViewSection
Visual C++
public:
static ViewSection^ CreateDetailSection(
	Document^ document, 
	ElementId^ assemblyInstanceId, 
	AssemblyDetailViewOrientation direction, 
	ElementId^ viewTemplateId, 
	bool isAssigned
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to which the view will be added.
assemblyInstanceId
Type: Autodesk.Revit.DBElementId
Id of the assembly instance that owns the new view.
direction
Type: Autodesk.Revit.DBAssemblyDetailViewOrientation
The direction for the new view.
viewTemplateId
Type: Autodesk.Revit.DBElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
isAssigned
Type: SystemBoolean
If true, the template will be assigned; if false, the template will be applied.

Return Value

A new detail section assembly view.

Remarks

The detail section will cut through the center of the assembly instance's outline. The document must be regenerated before using the detail section.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the geom view.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also