CanSuppressLeadingZeros Method (ForgeTypeId)


Checks whether leading zeros can be suppressed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static bool CanSuppressLeadingZeros(
	ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function CanSuppressLeadingZeros ( _
	unitTypeId As ForgeTypeId _
) As Boolean
Visual C++
public:
static bool CanSuppressLeadingZeros(
	ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the unit.

Return Value

True if leading zeros can be suppressed, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also