SetModeOverride Method


Sets color settings for the given color mode.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public void SetModeOverride(
	PointCloudColorMode mode,
	PointCloudColorSettings colorSettings
)
Visual Basic
Public Sub SetModeOverride ( _
	mode As PointCloudColorMode, _
	colorSettings As PointCloudColorSettings _
)
Visual C++
public:
void SetModeOverride(
	PointCloudColorMode mode, 
	PointCloudColorSettings^ colorSettings
)

Parameters

mode
Type: Autodesk.Revit.DBPointCloudColorMode
Color mode for which color settings are set.
colorSettings
Type: Autodesk.Revit.DB.PointCloudsPointCloudColorSettings
Color settings to be set for the given color mode.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also