Sets the documentation string for the Field.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- documentation
- Type: SystemString
The documentation string.
Return Value
The FieldBuilder object may be used to add more details to the field.Remarks
While Entities may be hidden using access levels, Schemas and Fields are visible to clients and other developers. In the interest of clarity and interoperability, you are very strongly encouraged to provide good documentation with your Schemas. Explain the intent of the data and how it is meant to be interpreted. It is not useful to repeat information that can be observed directly (e.g. types and units). Note that documentation, like all other contents of Schemas and Fields is immutable once the add-in using the Schema is published.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The SchemaBuilder has already finished building the Schema. |