AddCurvesToFaceRegion Method


Adds The CurveElements to one or more FaceRegions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static void AddCurvesToFaceRegion(
	Document document,
	IList<ElementId> curveElemIds
)
Visual Basic
Public Shared Sub AddCurvesToFaceRegion ( _
	document As Document, _
	curveElemIds As IList(Of ElementId) _
)
Visual C++
public:
static void AddCurvesToFaceRegion(
	Document^ document, 
	IList<ElementId^>^ curveElemIds
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The Document.
curveElemIds
Type: System.Collections.GenericIListElementId
The ElementIds of CurveElements which are to define the FaceRegion.

Remarks

The CurveElements that are input may produce an arbitrary number of regions.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException All the input CurveElements must be CurveByPoints, with the sketchOnSurface attribute set to True, and for each CurveElement, the defining ReferencePoints must be hosted on References related to a common Face or Edge.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Failed to add curves to FaceRegion.

See Also