Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DBFace
A face of a geometry object.
- location
- Type: Autodesk.Revit.DBXYZ
Point on the face where the instance is to be placed.
- referenceDirection
- Type: Autodesk.Revit.DBXYZ
A vector that defines the direction of the family instance.
- symbol
- Type: Autodesk.Revit.DBFamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.