Returns the end position of the tag's leader that points to specified reference.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- referenceTagged
- Type: Autodesk.Revit.DBReference
The reference which is tagged.
Return Value
Point representing the end position of tag's leaderRemarks
Tags with attached leaders or no leaders do not support leader ends. LeaderEndCondition for the tag's leader condition.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | There is no leader end because the tag does not use a free end leader or the leader is not visible. -or- The specified reference is not currently tagged. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The IndependentTag object does not have a tag behavior. |