Adds points to a topography surface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- points
- Type: System.Collections.GenericIListXYZ
A collection of points to be added.
Remarks
If an input point already exists in the surface at the same XY location, the point will not be added. The document will be regenerated by this function. This applies to a TopographySurface element (not a SiteSubRegion or a topography surface associated with a BuildingPad), which should be in an active TopographyEditScope.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | There are no points in the input points set. -or- One or more points shared the same XY location (even with different elevations). This is not permitted for topography surfaces. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This element is not a TopographySurface. -or- The topography surface is not editable. -or- The points of this topography surface are not editable. -or- The TopographySurface element is not in an active TopographyEditScope. Modification cannot be made on this TopographySurface. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document containing this TopographySurface is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this TopographySurface is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document containing this TopographySurface has no open transaction. |