CreateDefault Method


Creates a BuildingPadType element and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public static BuildingPadType CreateDefault(
	Document document
)
Visual Basic
Public Shared Function CreateDefault ( _
	document As Document _
) As BuildingPadType
Visual C++
public:
static BuildingPadType^ CreateDefault(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to be modified.

Return Value

The new BuildingPadType element.

Remarks

The default BuildiPadType adopts the value of 1.0 for the paremeter of thickness. If there is no BuildingPadType existing, will create a new one; otherwise, an exception will be thrown.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also