ChangeSection Method


The method that will be called when user wants to change beam section

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
bool ChangeSection(
	Document doc,
	ElementId idElem
)
Visual Basic
Function ChangeSection ( _
	doc As Document, _
	idElem As ElementId _
) As Boolean
Visual C++
bool ChangeSection(
	Document^ doc, 
	ElementId^ idElem
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
Revit document
idElem
Type: Autodesk.Revit.DBElementId
id of the selected element

Return Value

Indicates whether the operation succeeded or not

See Also