Project a 3D point orthogonally onto a surface (to find the nearest point). This method is meant to be used when a good approximate solution for the projection is available. Throws InvalidOperationException if the projection fails.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DBXYZ
The point to project.
- guessUV
- Type: Autodesk.Revit.DBUV
The calculation will look for a project near the provided UV.
- uv
- Type: Autodesk.Revit.DBUV%
The surface coordinates of the projected point.
- distance
- Type: SystemDouble%
Holds the distance from input point to its projection.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The projection failed. |