WallFoundationType Class


An object that represents the type of a wall foundation in Autodesk Revit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public class WallFoundationType : HostObjAttributes
Visual Basic
Public Class WallFoundationType _
	Inherits HostObjAttributes
Visual C++
public ref class WallFoundationType : public HostObjAttributes

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBHostObjAttributes
        Autodesk.Revit.DBWallFoundationType

See Also