CycleCounter Property


Identifies the cycle counter. It can be zero or a pozitive number.

Its value is changed when the free form Rebar element is selected and the user press Space key -or- through the setter of this property -or- by the server if it considers that the counter reaches the maximum value and reset it (set it to 0). This property can be accessed just for Rebars that are controlled by a server.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024

Syntax

C#
public int CycleCounter { get; set; }
Visual Basic
Public Property CycleCounter As Integer
	Get
	Set
Visual C++
public:
property int CycleCounter {
	int get ();
	void set (int value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The given value for cycleCounter is negative.
Autodesk.Revit.Exceptions InvalidOperationException This RebarFreeFormAccessor doesn't contain a valid rebar reference. -or- This RebarFreeFormAccessor Rebar doesn't contain a valid server GUID.

See Also