GetNumberOfRules Method


The number of RoutingPreference rules in a group.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public int GetNumberOfRules(
	RoutingPreferenceRuleGroupType eGroupType
)
Visual Basic
Public Function GetNumberOfRules ( _
	eGroupType As RoutingPreferenceRuleGroupType _
) As Integer
Visual C++
public:
int GetNumberOfRules(
	RoutingPreferenceRuleGroupType eGroupType
)

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also