Set the position of the elbow of the tag's leader that points to specified reference. If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- referenceTagged
- Type: Autodesk.Revit.DBReference
The reference which is tagged.
- elbowPosition
- Type: Autodesk.Revit.DBXYZ
The position of the elbow.
Remarks
Straight leaders do not have elbow points.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The specified reference is not currently tagged. -or- The leader for the tagged reference isn't visible. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The IndependentTag object does not have a tag behavior. |