RenameCurrentType Method


Rename the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RenameCurrentType(
	string typeName
)
Visual Basic
Public Sub RenameCurrentType ( _
	typeName As String _
)
Visual C++
public:
void RenameCurrentType(
	String^ typeName
)

Parameters

typeName
Type: SystemString
The new name of the current family type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument-"typeName"-is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when the input argument-"typeName"-is already in use.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the family type rename failed.

See Also