Removes a subelement from the element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- subelem
- Type: Autodesk.Revit.DBSubelement
The subelement to delete.
Return Value
True if entire element was deleted, false otherwise.Remarks
Depending on implementation for given element as the result, the element can be deleted - especially if after subelement deletion there are no subelements left. See also: IsModifiable.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The subelement subelem does not exist in the element. -or- Subelement subelem cannot be deleted. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | This Element is an internal element, such as a component of a loaded family or a group type. -or- The document containing this Element is in Group Edit Mode, Sketch Edit Mode, or Paste Mode, and the element is not a member of the group, sketch, or clipboard. -or- This Element is a member of a group or sketch, and the document is not currently editing the group or sketch. |