Reloads the image in the ImageType from a new image file, and for a new PageNumber.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- options
- Type: Autodesk.Revit.DBImageTypeOptions
Options that specify what image to load.
Remarks
If reload fails (because the image file doesn't exist, cannot be read, or does not have the requested page number), the currently loaded image will remain unchanged.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | options.Path is an empty string. -or- The file represented by options.Path is not a supported image file type. -or- The image file represented by options.Path is a password protected PDF file. -or- The image file represented by options.Path does not contain the page specified by options.PageNumber. -or- The image file represented by options.Path could not be read and may be corrupt. -or- An error occurred while handling the external resource corresponding to the image. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsFileArgumentNotFoundException | The file represented by options.Path does not exist. |
Autodesk.Revit.ExceptionsInvalidOperationException | This ImageType was not loaded from a file. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document containing this ImageType is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document containing this ImageType is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document containing this ImageType has no open transaction. |