Gets or sets the current PushButton of the SplitButton.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
This property is applicable only if IsSynchronizedWithCurrentItem is true. The default value of this property will be the first enabled PushButton in the drop down list after the SplitButton is shown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when trying to set the CurrentButton to a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when trying to set the CurrentButton to a button which is not in current drop-down list. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when trying to set the CurrentButton if IsSynchronizedWithCurrentItem is false. |