CategoryType Property


The category type which this layer belongs to.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public LayerCategoryType CategoryType { get; set; }
Visual Basic
Public Property CategoryType As LayerCategoryType
	Get
	Set
Visual C++
public:
property LayerCategoryType CategoryType {
	LayerCategoryType get ();
	void set (LayerCategoryType value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also