AsBoolean Method


Gets storage value as boolean when its PrimitiveType is boolean.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public bool AsBoolean()
Visual Basic
Public Function AsBoolean As Boolean
Visual C++
public:
bool AsBoolean()

Return Value

The bool value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInapplicableDataException The primitive type is not boolean.

See Also