ClassName Property


The name of the class containing the implementation for the command.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public string ClassName { get; set; }
Visual Basic
Public Property ClassName As String
	Get
	Set
Visual C++
public:
property String^ ClassName {
	String^ get ();
	void set (String^ value);
}

Remarks

The class name which implements the interface IExternalCommand.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when setting the value to a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentExceptionThrown when setting the value to an empty string.

See Also