IsValidTime Method


Check if the string can be parsed to a valid time for opening time and closing time. A valid string can be "16:30" or "4:30 PM";

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static bool IsValidTime(
	string hourMinute
)
Visual Basic
Public Shared Function IsValidTime ( _
	hourMinute As String _
) As Boolean
Visual C++
public:
static bool IsValidTime(
	String^ hourMinute
)

Parameters

hourMinute
Type: SystemString

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also