PaperSource Property


The page source.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperSource PaperSource { get; set; }
Visual Basic
Public Property PaperSource As PaperSource
	Get
	Set
Visual C++
public:
property PaperSource^ PaperSource {
	PaperSource^ get ();
	void set (PaperSource^ value);
}

Remarks

User can select the candidate via PaperSources and then set the Page source of the Print Setting.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when the input argument is invalid for current printer.

See Also