SetRuleEnabled Method (Int32, Boolean)


Retrieves an enabled/disabled status for the given rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void SetRuleEnabled(
	int index,
	bool enabled
)
Visual Basic
Public Sub SetRuleEnabled ( _
	index As Integer, _
	enabled As Boolean _
)
Visual C++
public:
void SetRuleEnabled(
	int index, 
	bool enabled
)

Parameters

index
Type: SystemInt32
The rule index to set enabled/disabled status for.
enabled
Type: SystemBoolean
True enables the rule, false disables.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The index is outside of acceptable range.

See Also