Adds a new pushbutton to the pulldown button and associates it with an ExternalCommand.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- buttonData
- Type: Autodesk.Revit.UIPushButtonData
An object containing the data needed to construct the pushbutton.
Return Value
The newly added pushbutton.Remarks
The new button will display its large image if PushButton.LargeImage is set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when buttonData is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when button with buttonData.Name already exists in the button. |