GetCableTraySettings Method


Gets the cable tray settings of the project.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public static CableTraySettings GetCableTraySettings(
	Document document
)
Visual Basic
Public Shared Function GetCableTraySettings ( _
	document As Document _
) As CableTraySettings
Visual C++
public:
static CableTraySettings^ GetCableTraySettings(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.

Return Value

The cable tray settings of the project.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also