AnalyticalElement Class


Base class for a structural analytical elements. AnalyticalElement represents the analytical portion of a given Structural Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public class AnalyticalElement : Element
Visual Basic
Public Class AnalyticalElement _
	Inherits Element
Visual C++
public ref class AnalyticalElement : public Element

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.StructureAnalyticalElement
      Autodesk.Revit.DB.StructureAnalyticalMember
      Autodesk.Revit.DB.StructureAnalyticalSurfaceBase

See Also