Adds a CommandLink associated to the given id, displaying the indicating main content.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- id
- Type: Autodesk.Revit.UITaskDialogCommandLinkId
The id of the CommandLink. This corresponds to the value returned by Show() when the link is chosen by the user.
- mainContent
- Type: SystemString
The main content of the CommandLink.
Remarks
Parameter mainContent cannot contain newlines.
If the id has already been set to the task dialog, the new CommandLink definition overrides the old one.
CommandLinks will always be shown in the dialog in the order of their ids.