FilterGlobalParameterAssociationRule Constructor


Constructs an instance of FilterGlobalParameterAssociationRule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public FilterGlobalParameterAssociationRule(
	FilterableValueProvider valueProvider,
	FilterNumericRuleEvaluator evaluator,
	ElementId ruleValue
)
Visual Basic
Public Sub New ( _
	valueProvider As FilterableValueProvider, _
	evaluator As FilterNumericRuleEvaluator, _
	ruleValue As ElementId _
)
Visual C++
public:
FilterGlobalParameterAssociationRule(
	FilterableValueProvider^ valueProvider, 
	FilterNumericRuleEvaluator^ evaluator, 
	ElementId^ ruleValue
)

Parameters

valueProvider
Type: Autodesk.Revit.DBFilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
evaluator
Type: Autodesk.Revit.DBFilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test. The built-in evaluators implement commonly used tests such as less-than, greater-than less-than-or-equal-to, equal, etc.
ruleValue
Type: Autodesk.Revit.DBElementId
The user-supplied global parameter value against which values from a Revit document will be tested.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also