Get an Opening ConceptualConstructionType by its ConceptualConstructionOpeningType.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ccda
- Type: Autodesk.Revit.DBDocument
The Document.
- typeEnum
- Type: Autodesk.Revit.DB.AnalysisConceptualConstructionOpeningType
The ConceptualConstructionOpeningType to get the ConceptualConstructionType for.
Return Value
Returns ElementId of a ConceptualConstructionType.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The enum is invalid for ConceptualConstructionOpeningType. -or- A value passed for an enumeration argument is not a member of that enumeration |