ServerSupports Method


Checks if the server referenced by the given ExternalResourceReference supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public bool ServerSupports(
	ExternalResourceReference extRef
)
Visual Basic
Public Function ServerSupports ( _
	extRef As ExternalResourceReference _
) As Boolean
Visual C++
public:
bool ServerSupports(
	ExternalResourceReference^ extRef
)

Parameters

extRef
Type: Autodesk.Revit.DBExternalResourceReference
The ExternalResourceReference to check.

Return Value

True if the ExternalResourceReference refers to a server that supports the ExternalResourceReferenceType of this KeyBasedTreeEntryTable. False otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also