CreateLessOrEqualRule Method (ElementId, String)


Creates a filter rule that determines whether strings from the document are less than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public static FilterRule CreateLessOrEqualRule(
	ElementId parameter,
	string value
)
Visual Basic
Public Shared Function CreateLessOrEqualRule ( _
	parameter As ElementId, _
	value As String _
) As FilterRule
Visual C++
public:
static FilterRule^ CreateLessOrEqualRule(
	ElementId^ parameter, 
	String^ value
)

Parameters

parameter
Type: Autodesk.Revit.DBElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: SystemString
The user-supplied string value against which values from the document will be compared.

Return Value

Created filter rule object.

Remarks

For strings, a value is "less" than another if it would appear before the other in an alphabetically-sorted list.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also