UpdateControl Method


Updates the in-canvas control identified by the unique index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void UpdateControl(
	int index,
	InCanvasControlData data
)
Visual Basic
Public Sub UpdateControl ( _
	index As Integer, _
	data As InCanvasControlData _
)
Visual C++
public:
void UpdateControl(
	int index, 
	InCanvasControlData^ data
)

Parameters

index
Type: SystemInt32
Unique index of the control to be updated.
data
Type: Autodesk.Revit.DBInCanvasControlData
data to generate in-canvas control appearance.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException index is out of range of TemporaryGraphicsManager managed objects, or the indexed object has been removed from the document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Failed to load the image from specified path.

See Also