AddSize Method


Inserts a new MEPSize in to the duct size settings. The duct shape determines the location of the new size in the size table.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void AddSize(
	DuctShape shape,
	MEPSize sizeInfo
)
Visual Basic
Public Sub AddSize ( _
	shape As DuctShape, _
	sizeInfo As MEPSize _
)
Visual C++
public:
void AddSize(
	DuctShape shape, 
	MEPSize^ sizeInfo
)

Parameters

shape
Type: Autodesk.Revit.DB.MechanicalDuctShape
The shape of duct.
sizeInfo
Type: Autodesk.Revit.DBMEPSize
The new MEPSize to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Throws if there is no size set determined by the duct shape or there is already the same size in the size set determined by the duct shape.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException Throws if the function is called during iterating the size set.

See Also