SupportLayout Property


The support layout method of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public RailSupportsLayout SupportLayout { get; set; }
Visual Basic
Public Property SupportLayout As RailSupportsLayout
	Get
	Set
Visual C++
public:
property RailSupportsLayout SupportLayout {
	RailSupportsLayout get ();
	void set (RailSupportsLayout value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException When setting this property: The rail has no support specified so the data being set is not applicable.

See Also