SetLevelId Method


Set the level for a View Depth plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void SetLevelId(
	PlanViewPlane planViewPlane,
	ElementId id
)
Visual Basic
Public Sub SetLevelId ( _
	planViewPlane As PlanViewPlane, _
	id As ElementId _
)
Visual C++
public:
void SetLevelId(
	PlanViewPlane planViewPlane, 
	ElementId^ id
)

Parameters

planViewPlane
Type: Autodesk.Revit.DBPlanViewPlane
The View Depth plane
id
Type: Autodesk.Revit.DBElementId
Id of the level

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also