Validates the point object to be added to the wireframe shape being constructed. Used by AddPoint() to validate input.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- GPoint
- Type: Autodesk.Revit.DBPoint
Point object to be validated.
Return Value
True is %GPoint% is acceptable as a part of a wireframe shape representation being built.Remarks
This function may be used to pre-validate the geometry being added to avoid an exception from AddPoint().
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |