SetSelection Method


Set the element selection to change the service or size for.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.2

Syntax

C#
public FabricationNetworkChangeServiceResult SetSelection(
	ISet<ElementId> selection
)
Visual Basic
Public Function SetSelection ( _
	selection As ISet(Of ElementId) _
) As FabricationNetworkChangeServiceResult
Visual C++
public:
FabricationNetworkChangeServiceResult SetSelection(
	ISet<ElementId^>^ selection
)

Parameters

selection
Type: System.Collections.GenericISetElementId
The set of element identifiers of fabrication parts to change the service or size for.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also