Creates a new parameter binding between a parameter and a set of categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- key
- Type: Autodesk.Revit.DBDefinition
A parameter definition which can be an existing definition or one from a shared parameters file.
- item
- Type: Autodesk.Revit.DBBinding
An InstanceBinding or TypeBinding object which contains the set of categories to which the parameter should be bound.
Remarks
Note the type of the binding object dictates whether the parameter is bound to all instances or just types. A parameter definition cannot be bound to both instances and types. If the parameter binding already exists, post an error and return false.