Removes component repeaters from the document, but leaves the individual repeated components in their respective locations and hosted on their original hosts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document that contains the component repeaters to remove.
- elementIds
- Type: System.Collections.GenericISetElementId
The set of component repeaters that should be removed.
Return Value
A collection of components that were previously repeated by the component repeater.Remarks
In addition to the component repeaters the component repeater slots are also removed from the document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given element id set is empty. -or- One or more elements in elementIds do not exist in the document. -or- Not all given elements are component repeaters. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |