Reorders the family parameters by the specified parameters order.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameters
- Type: System.Collections.GenericIListFamilyParameter
The new parameters order for the family. The contents of this collection should consist of exactly the same parameters returned by the GetParameters() method. This will include invisible parameters; they can be reordered but this will have no effect when viewing the parameters in the Revit UI.
Remarks
Reordering the parameters only affects visible parameters within the same parameter group.
Parameters that belong to different groups will remain separated, and the groups' order will not be affected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when argument is a null reference (Nothing in Visual Basic) or empty. |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the input parameters collection does not contain the same parameters as those returned by GetParameters(). |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when this family is a Rebar Shape family which doesn't support parameters reorder. |