Add elements into the system and connect them with the system using given connectors.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- connectors
- Type: Autodesk.Revit.DBConnectorSet
Connectors which are used to connect with the system.
Remarks
Note: this method may not be called during dynamic update.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument connectors is a null reference (Nothing in Visual Basic), or any connector in that collection is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Throw when any of the input connectors have been already used, or when they don't share the same domain or system type as the system. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the operation failed. |
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update. |